Library import issue in Intelij Idea and Play FrameworkAsk Question


I have project that used Play Framework 2.3.4 and Slick 2.1.0. Intelij Idea version is 13.1.4, with installed Scala and Play 2.0 plugins.

When I trying to import database driver

import play.api.db.slick.Config.driver.simple._

Idea writes me that this import is incorrect, and they cant resolve it. But if I run application, they will compiled and executed correctly.

Did someone knows how to fix Idea imports? Because without it, features like auto substitution will not working.


I found the solution of this problem:

  1. Compile play project through terminal
  2. In Intelij Idea use "Cache Invalidating" (File->Invalidate caches/Restart->Invalidate and restart)
  3. Wait until Idea restarts and indexing project
  4. Profit
标签: intellij-idea playframework-2.0 slick
© 2014 TuiCode, Inc.