R package DESCRIPTION - Remotes from Bioconductor should install binaryAsk Question

问题:

I am working on an R package (https://github.com/bgbrink/dropClust) and I was testing if it can be installed, since it depends on a number of packages both from CRAN and from Bioconductor. I specified the three dependencies from Bioconductor in the DESCRIPTION:

Remotes: 
bioc::flowDensity, 
bioc::SamSPECTRAL, 
bioc::flowPeaks

However, when I try to install the package, the installation of flowPeaks fails, because the script downloades the source version of the package, which requires GSL to be present in order to be compiled.

* installing *source* package ‘flowPeaks’ ...
** libs
clang++  -I/Library/Frameworks/R.framework/Resources/include -DNDEBUG   -I/usr/local/include  `gsl-config --cflags`  -fPIC  -Wall -g -O2  -c Rpack.cpp -o Rpack.o
/bin/sh: gsl-config: command not found
In file included from Rpack.cpp:16:
./gvector_gmatrix.h:24:10: fatal error: 'gsl/gsl_math.h' file not found
#include <gsl/gsl_math.h>
         ^
1 error generated.
make: *** [Rpack.o] Error 1
ERROR: compilation failed for package ‘flowPeaks’

When I download the package manually from Bioconductor, everything works fine, because the script downloades the binary version of the package. Can I specify somewhere that this is the default behaviour? I tried options(pkgType = "binary") without success.

Edit: No new ideas, so I'm bumping it once.

标签: bioconductor r-package
© 2014 TuiCode, Inc.